Question

Why can't I download the javax.transaction:jta:1.0.1B JAR? The pom file is present, but the jar is missing.

Answer

Unfortunately that's a legacy library that is not available from Maven Central.

It isn't available because there are still some old Sun-era Javax JARS that are not covered under open source licenses.  If you need to access this JTA 1.0.1B library, you will need to replace that dependency using an exclusion.

Section 3.4.5 of the Maven Book details this process.

For example, if I were going to replace the javax.transaction:jta library dependency of Hibernate with the compatible open-source version, I would use the following XML. The exclusion excludes it as a transitive dependency of Hibernate and the second dependency is on the Apache Geronimo version.

<dependencies>  
 <dependency>  
   <groupId>org.hibernate</groupId>  
   <artifactId>hibernate</artifactId>  
   <version>3.2.5.ga</version>  
   <exclusions>  
     <exclusion>  
       <groupId>javax.transaction</groupId>  
       <artifactId>jta</artifactId>  
     </exclusion>  
   </exclusions>  
 </dependency>  
 <dependency>  
   <groupId>org.apache.geronimo.specs</groupId>  
   <artifactId>geronimo-jta_1.1_spec</artifactId>  
   <version>1.1</version>  
 </dependency>  
</dependencies>